This article will walk you through how to create contour files from a DEM using either QGIS or Global Mapper.

Prerequisites

  • A: QGIS on your computer. Don't have it? Follow these instructions to install it.
    or
  • B: Global Mapper on your computer. Don't have it? Purchase it from their website.

Instructions - A: Using QGIS

 1. Launch QGIS.

2. Import the DEM file by clicking Layer > Add Layer > Add Raster Layer.

3. To generate the contours, navigate to Raster > Extraction > Contour, then fill in the:
    a) Input file,
    b) Output filename for the contour and
    c) Desired contour interval.
Once they're filled in, click OK.

4. Right click on the generated contour layer and click "Save As..." (you will find the layers panel on the left of the window).

5. This will prompt the dialogue box which enables you to:
    a) Select your desired file format (DXF, SHP, KML, GML),
    b) Enter a filename for the contour data and
    c) Choose the coordinate reference system (CRS) of the output file.

6. Click OK and you're done! The generated contour file is now saved in your chosen directory.
--------------------------------------------------------------------------------------------------------------------

Instructions - B: Using Global Mapper

 1. Launch Global Mapper.

2. Import your data file by navigating to File > Open Data File.

3. Once the elevation file is imported, create contour lines by navigating to Analysis > Generate Contours (from Terrain Grid).

4. In the Contour Generation dialogue box, enter:
    a) Contour filename,
    b) Contour interval and units (meters or feet),
    c) Minor and major contour interval, and
    d) Maximum and minimum range of elevations and units (meters or feet).
Once all the parameters are set, click OK. 

5.  Once the contour has been generated, navigate to the Current Workspace, right click the contour file layer > Layer > Export.

6. Choose your desired file format and click OK.

7. You're done! The generated contour file is now saved in your chosen directory.

I still can't do it!

We wrote these articles to arm you with everything you need to get the job done on your own, but we understand that sometimes this isn't sufficient.

If you're stuck, the Propeller data specialists team can help for an hourly consulting rate. Email us at support@propelleraero.com or talk with us right now from the chat bubble and we'll do our best to help.

Did this answer your question?