How to Create Contour files (DWG/DXF/SHP) From DEM (GeoTIFF) Using QGIS or Global Mapper


This article will walk you through creating contour files from a DEM using either QGIS or Global Mapper.

QGIS

If you haven't already, install QGIS on your computer. If you are using a Windows computer, it is recommended to download the long-term release (most stable) standalone installer. 
1. Launch QGIS.
2. Import the DEM file by clicking Layer > Add Layer > Add Raster Layer.
QGIS_Import.png
3. To generate the contours, navigate to Raster > Extraction > Contour, then provide:
  • Input file
  • Output filename for the contour
  • Desired contour interval
Once they're filled in, click OK.
QGIS_Extraction.png
4. Right click on the generated contour layer and click "Save As...". (You will find the layers panel on the left of the window).

QGIS_SaveAs.pngQGIS_Import.png

5. This will prompt the dialogue box, which enables you to:

a. Select your desired file format (DXF, SHP, KML, GML),
b. Enter a filename for the contour data, and
c. Choose the coordinate reference system (CRS) of the output file.

QGIS_Vector.png

6. Click OK. The generated contour file is now saved in your chosen directory.

Global Mapper

 1. Launch Global Mapper.

2. Import your data file by navigating to File > Open Data File.

GlobalMapper_File.png

3. Once the elevation file is imported, create contour lines by navigating to Analysis > Generate Contours (from Terrain Grid).

GlobalMapper_GenerateContours.png

4. In the Contour Generation dialogue box, enter
a. Contour filename,
b. Contour interval and units (meters or feet),
c. Minor and Major contour interval, and
d. Maximum and Minimum range of elevations and units (meters or feet).
Once all the parameters are set, click OK. 

GlobalMapper_ContourOptions.png

5.  Once the contour has been generated, navigate to the Current Workspace, right click the contour file layer > Layer > Export.
GlobalMapper_Export.png

6. Choose your desired file format and click OK.

7. The generated contour file is now saved in your chosen directory.


I still can't do it!

We wrote these articles to equip you with everything you need to get the job done on your own, but we understand that sometimes this isn't sufficient. If you're stuck, you can connect with our support team by clicking the support button on the top right corner of your user portal.